WordPress выпускает версию 4.9.2, в которой починили уязвимость XSS и 21 баг предыдущих версий

16 января 2018 сообщество WordPress опубликовало версию 4.9.2. Это версия, которая применима ко всем версиям WordPress выше 3.7.

WordPress выпустила новую версию 4.9.2

В последней версии WordPress исправлена уязвимость XSS, которая была обнаружена в флэш-файлах типа fallback в библиотеке MediaElement 4.x. Библиотека MediaElement в WordPress предназначена для продвинутого проигрывания аудио и видео.

WordPress обновили библиотеку MediaElement и убрали флэш-файлы типа fallback из-за небольшого спроса на них и проблем безопасности.

Кроме этого, в обновленной версии разработчики починили еще 21 баг, включая ошибки JavaScript, которые не давали сохранять посты в Firefox. Пользователи теперь могут восстанавливать предыдущие виджеты при смене темы, и им не нужно будет при этом преобразовывать боковую панель сайта. WordPress также восстановил предыдущее платформенно-независимое поведение элементов get_category_link() and category_description().

Версия WordPress 4.9.2 улучшает процесс дизайна и предоставляет более тщательную функцию проверки кода на ошибки и подсвечивания синтаксиса кода, чтобы пользователям было удобнее. для приятного пользовательского опыта.

В октябре 2017 была обнаружена уязвимость внедрения SQL-кода, которая могла привести к взлому сайтов. Это была крупная атака, и WordPress пришлось выпустить версию 4.8.3 с обновлениями безопасности.

Когда команда разработчиков WordPress выпустила версию 4.9 в ноябре 2017, они назвали ее WordPress 4.9 «Tipton», чтобы почтить память американского джазового музыканта Билли Типтона.

Пользователи могут обновиться до последней версии, используя опцию Обновления в админке WordPress. Сайты, где настроены фоновые автоматические обновления, обновятся автоматически.

Источник: статья в издании Daily Host News

Понравилась статья? Оставь свой голос!
Звёзд: 1Звёзд: 2Звёзд: 3Звёзд: 4Звёзд: 5 (2 оценок, среднее: 5,00 из 5)
Загрузка...