установка eAccelerator без Apache2

Тему в разделе "Gentoo", создал(-а) Oleg, 04.08.2013.

  1. Oleg

    Oleg Новичок

    Есть сервер с установленным Nginx + php-fpm без Apache2.
    Нужно установить eAccelerator. Перепробовал все, но без Apache2 ставиться не хочет...
     
  2. Alex

    Alex Новичок

    Что пробовал, что пишет?
     
  3. Oleg

    Oleg Новичок

    * You did not enable apache2 USE flag, so you need to define
    * the user and group that will be used for eaccelerator yourself.
    *
    * This should (generally) match the user and group that your webserver uses, e.g.:
    * HTTPD_USER="lighttpd" HTTPD_GROUP="lighttpd" if using www-servers/lighttpd
    *
    * ERROR: dev-php5/eaccelerator-0.9.6.1 failed:
    * Either enable USE="apache2" or re-emerge this with HTTPD_USER and HTTPD_GROUP set
    *
    * Call stack:
    * ebuild.sh, line 56: Called pkg_setup
    * eaccelerator-0.9.6.1.ebuild, line 50: Called die
    * The specific snippet of code:
    * die "Either enable USE=\"apache2\" or re-emerge this with HTTPD_USER and HTTPD_GROUP set"
    *
    * If you need support, post the output of 'emerge --info =dev-php5/eaccelerator-0.9.6.1',
    * the complete build log and the output of 'emerge -pqv =dev-php5/eaccelerator-0.9.6.1'.
    * The complete build log is located at '/var/tmp/portage/dev-php5/eaccelerator-0.9.6.1/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/dev-php5/eaccelerator-0.9.6.1/temp/die.env'.
    * S: '/var/tmp/portage/dev-php5/eaccelerator-0.9.6.1/work/eaccelerator-0.9.6.1'
     
  4. Alex

    Alex Новичок

    Я думаю что проблема в ""Either enable USE=\"apache2\" or re-emerge this with HTTPD_USER and HTTPD_GROUP set""
     
  5. Oleg

    Oleg Новичок

    Нашел решение:
    Код:
    echo 'HTTPD_USER="nginx"' >> /etc/make.conf
    echo 'HTTPD_GROUP="nginx"' >> /etc/make.conf
    emerge dev-php5/eaccelerator
     
    Wolverine нравится это.

Поделиться этой страницей