Ошибка после обновления версии PHP с 5.1 на 5.3

Тему в разделе "VPS", создал(-а) Midnight, 29.03.2015.

  1. Midnight

    Midnight Любопытный

    После обновления версии PHP с 5.1 на 5.3 перестал работать сайт на CMS. И в базах данных выдает ошибку Function ereg_replace() is deprecated in.

    Что делать?
     
  2. Wolverine

    Wolverine Moderator

    Указанная Вами ошибка говорит о том, что CMS использует функцию ereg_replace(), которая более не поддерживается интерпретатором, и необходимо заменить ее функцией preg_replace(), которую следует использовать. Данная информация также освещена на официальном сайте PHP -http://php.net/manual/ru/function.ereg-replace.php
     

Поделиться этой страницей